
MODULE 1: AN INTRODUCTION TO VIRTUAL REALITY DEVELOPMENT IN 
UNITY 

OVERVIEW 

By the end of this lab, you will be able to: 
 Navigate the Unity editor to use common commands and tasks. 
 View and move in Game View to see how your application is progressing. 
 Add Game Objects to an existing Unity scene. 
 Create a new Unity scene. 
 Add a Google VR (Daydream) camera element to an existing camera in a Unity scene. 

PART 1: GETTING FAMILIAR WITH UNITY 

What is a game engine, and why choose one for building immersive content? A game engine is a software tool 
used that provides a framework for building games and supports a number of common features and plugins 
available to common features for building. The Unity 3D engine is just one of many tools for creating VR and AR 
content. The editor contains several components that make it a powerful choice in getting started with VR and AR 
development right away: 

 A 3D editor for creating scenes and environments 
 Component-based objects to create reusable assets in your application 
 Built-in lighting, rendering, movement, and physics engines that provide underlying 
 functionality for application elements 
 Several scripting languages to choose from to write and control game 
 An asset store for selling and purchasing pre-made components, including models, 
 textures, materials, scripts, and more 

Different VR manufacturers have their own ways of implementing the underlying functionality for their hardware 
with their software development kits (SDKs), but Unity (like several other major game engines) has also integrated 
support for VR development directly into the 
engine. We’ll start with the Daydream Google VR SDK, which will let us use Unity to write an 
application for an iPhone or Android device. Note: If you choose to develop for iOS, you will need to have access to 
a Mac OS X computer to finalize the application. 

BUILDING A VR EXPERIENCE IN UNITY 

This module will cover step by step how to go through the process of creating your first Unity scene. We will be 
starting out our project, a Space VR app, and will spend some time covering the basics of the Unity Editor.  

After completing this lab, we will have a Unity scene with a single planet that we will build off of in the next 
module.  

SETUP 

Download and install Unity 3D from the Unity website. Select ‘Visual Studio 2017’ as an additional add-on. The 
version used for this project is 2018.2.6f1 

Launch Unity  

Create a Unity Account and sign in 



CREATE A NEW PROJECT 

1. On the Projects tab of the Unity launcher, select the [+ New] icon 
2. Name your project and select a location to save it in.  
3. Make sure that the 3D template is selected  
4. If you see an ‘Organization’ option, you can turn off the ‘Enable Unity Analytics’ slider 
5. Create your project!  

 

In Unity, your application will be comprised of scenes – collections of objects that make up a single snippet of 
behavior or activity within your application. You can find saved scenes in the Asset pane of the Unity Editor, under 
Assets/Scenes 

By default, the only things included in a new scene will be a camera object called ‘Main Camera’ and a directional 
light. Every scene that a player can view must have some kind of camera placed somewhere in the scene so that 
the computer knows how to draw the view of what is happening in our 3D world.  

 Rename your sample scene to ‘MainScene’ by opening up the ‘Scenes’ folder and right clicking on the 
‘SampleScene’ asset in the Asset Pane, then select ‘Rename’.  



 

Your Unity editor will be arranged in a configuration that is similar to the above image. Each of the different panels 
have a different functionality:  

 The Hierarchy lists everything that is in a specific scene. Individual items within the hierarchy are referred 
to as Game Objects, elements that make up the behaviors and visuals inside of your virtual space. 

 The Scene View is the visual representation of everything in your scene 
 The Game View is the visual representation of what the game camera will be seeing 
 The Asset Pane lists all of the project assets that are available to your project. An asset is a single piece of 

content (script, model, audio file, texture, material, etc.) that can contribute to your scene. 
 The Inspector window shows details about a selected game object’s property sets and allows you to 

configure individual components 

 CREATE A SKYBOX 

The first thing that we’ll want to do is create a skybox for our scene. The skybox is a box that surrounds the entire 
scene and is an infinite distance away from our viewer. For our scene, we’ll use the Unity Asset Store to find a 
suitable skybox for our app. 
 

SELECTING AND IMPORTING A SKYBOX PACKAGE FROM THE UNITY ASSET STORE 

1. At the top of the Unity window, select Window > General > Asset Store to open the Unity Asset Store. This 
is a collection of community and company-created assets, and where we’ll find our skybox. 

2. While you can choose your own skybox package if you want to find something different, we’re using the 
package GalaxyBox 2.0 for this tutorial. In the search bar, search for ‘GalaxyBox 2.0’ to find the package 
published by LemonSpawn. You can also add it to your available assets from the browser by clicking the 
link and signing in to your account, then adding it to your assets. 
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3. Click the ‘Download Button’ to download the free asset package and then ‘Import’ to import the objects 
into your asset collection for the project. 

4. When you import the package, deselect the following elements: 
a. Examplescene.unity 
b. Instructions.txt 
c. Scripts folder 

5. Select ‘Import’ at the bottom of the import window to add the asset to your project! 

When you have successfully imported the assets into your project, you will notice a new folder called ‘GalaxyBox2’ 
under your Assets. Within that is a folder named ‘Resources’, where you will see 11 skybox folders. Inside each 
folder is a skybox material and six skybox textures that make up the material.  

 

 
 
 

SETTING THE SKYBOX 
1. At the top of the Unity Editor window, select Window > Rendering > Lighting Settings to bring up the Inspector 
tab for our lighting settings.  
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2. The first section of the Lighting window is where our Environment Lighting is set. Click on the small circle directly 
to the right of the box labeled ‘Skybox’ to open a list of our available materials  
3. From the asset choosing window, select one of the skybox assets from the tab labeled ‘Assets’. This allows us to 
designate that we are choosing an asset from our game resources.  
4. When you confirm the selection for the skybox, you’ll notice that the editor reflects the change immediately and 
you can see how your sky looks. You can look around by holding down the right mouse button in the scene view to 
get a 360 view of the material you chose!  



 
 

SETTING UP GOOGLE VR SUPPORT 

Now that we have something in our scene to view, we’ll set up the camera to render it for viewing as if we were 
using a Google VR headset. First, we’ll have to update the player and build settings to adjust for using Android as 
our base platform – by default, Unity will be set up for Windows / OS X / Linux standalone applications.  

1. Open up File > Build Settings and select ‘Android’ 
2. Hit the ‘Switch Platform’ and the bottom and allow the project target to change – this may take a few 

minutes 
3. Open up the Player Settings by clicking the button – you won’t build the project until you’re ready to 

deploy it to a physical device. 
4. In the Inspector window Player Settings, click ‘XR Settings’ and check ‘Virtual Reality Supported’ 
5. Click the ‘+’ icon under ‘Virtual Reality SDKs’ and add the Daydream SDK. 
6. Download the Unity package for Google VR from their website here and drag the .unitypackage file into 

your Assets directory to import the package 
7. Open up Assets/GoogleVR/Prefabs and drag the GvrEditorEmulator into your SampleScene Hierarchy 

 

VIEWING YOUR SCENE 

As we work on our scene, we’ll want to make sure that we’re taking some time to go into play mode and view our 
work. This is especially important as we move forward and add in our VR camera, as we’ll want to be checking the 
first-person perspective with the objects in our scene. 

1. Click on the play button at the top of the window to launch your experience in game view. When game 
mode is live, you will be able to interact with your experience the way that a user would! 



Keep in mind that changes made to your app while you are in play mode do not persist when you end your play 
mode session! Being able to change things in play mode can be helpful to try out positioning in real time, but make 
sure that you aren’t in play mode when you want to make final changes to your experience. 

The GvrEditorEmulator prefab is a game object that will allow you to emulate the hardware and head movements 
of a VR viewer while in Unity’s play mode. You can use the chart below to understand how to interact with the 
editor using your mouse to emulate using a headset. 

 

Source: GoogleVR, https://developers.google.com/vr/develop/unity/get-started-android  

ADDING A PLANET TO OUR SCENE 

We are going to download another package from the Unity Asset Store to help us create our planet scene, this one 
with planets and other various space effects that you can use to build out your solar system. 
 

1. Go to Window > Asset Store in Unity to launch the Asset Store.  
2. At the top of the Asset Store home page, use the search box to for ‘Vast Outer Space’  
3. Click on the ‘Download’ button on the Vast Outer Space page to download the assets to Unity, then click 

on the ‘Import’ button to bring them all into the project.  
4. Once we’ve downloaded and imported the package, you should see a folder called ‘Vast Outer Space’ in 

your Assets folder at the bottom of the editor.  

ADDING MODELS TO OUR SCENE 
Now that we have a package to help us with our scene, we will go ahead and start building our first planets.  

1. Open the Vast Outer Space > Prefabs > Gas Planets to see the included prefabs. These models contain a 
geometry and material element, so we can simply use them as-in our project. The instructor will go into 
more detail about how the prefabs are created.  

2. Drag one of the Gas Planet prefabs into your scene by clicking on it in the Assets panel and dragging it to 
the Hierarchy tab on the left side of the editor. You should see it show up in the scene view, and locate 
where it is relative to your camera and the directional light.  



3. Move the planet so that it is located in front of the camera by modifying the position element in the 
Inspector window while the planet is selected in the hierarchy, or click and drag the arrows that appear 
on the planet when the editor is in position mode:  

 

 
 
4. Experiment with scaling your planet by modifying the scale property in the Inspector window while the 

planet is selected in the hierarchy, or click and drag the arrows that appear on the planet with the scaling 
buttons selected. The image on the left shows the isolated scale tool; right shows a combined scale, 
rotate, and position tool:  
 

    
 

Be creative and explore different things with your planet until it is a size and position you like. We’ll be adding in 
more planets to the scene as we go, so keep that in mind as you start to size and position the objects in the scene. 
Place several planets around the camera so that as you turn, you can see different ones, avoiding overlap or 
planets being placed too far away. 
 

LOOKING AHEAD 

In Module 2, we will work on implementing a user interface for our app. Finish your experience by adding more 
planets to your scene and customizing the way they look by changing materials, adding rings, asteroids, and more 
before progressing.  
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MODULE 2: BUILDING A USER INTERFACE IN UNITY 
How users learn to interact with and understand your application is a critical component for creating virtual reality 
experiences. We have learned, over the past several decades, design patterns for traditional software applications, 
but with virtual and augmented reality, the user interface needs to be reconsidered from the ground up. 
 
In this module, we will practice what we covered in Module 1 by learning how user interfaces are built in Unity to 
understand how we can begin building out interactive menus. We will create an environment using Unity's 3D 
editor and go hands-on with the implementation of a simple UI starting scene for our Space App. 
 

CREATING A MAIN MENU SCENE 

The first thing that we are going to create is a main menu scene for our app. This will give us a place where the 
user can land and get acclimated to our experience and launch the main scene. 

1. Click File > New Scene and name it MainMenu 
2. Following the instructions from Module 1, add your skybox to the scene that you created. 
3. Following the instructions from Module 1, add the GvrEditorEmulator to your scene 

Think about the elements that you would expect when first launching an application. We will be adding in three 
elements to our main menu: a title, an icon, and a button to launch our experience’s main scene. 

CANVASES AND EVENT SYSTEMS 

All UI elements in Unity require a Canvas object to be their parent. You may have more than one Canvas in your 
scene, but you cannot have elements such as text or buttons without a Canvas.  

1. Right click in the Inspector window and select UI > Canvas to add a Canvas element to your scene  
2. There are multiple types of canvas render modes you can choose from in a Unity scene:  

a. Screen Space – Overlay  
b. Screen Space – Camera  
c. World Space  

For VR, we’ll want our canvases to be tied into a world location, so change the Canvas > Render Mode to World 
Space by selecting it from the dropdown menu.  

When you add in a canvas to your scene for the first time, Unity will also automatically include an Event System 
game object. We’ll use this in the next lab to handle the interactions and events in our scene.  

We’ll want to modify a few things about our Canvas so that we can see it from our main camera:  

1. Select the Canvas element in the Hierarchy  
2. Under the ‘Rect Transform’ element, set the following attributes:  

a. Position: X = 0, Y = 0, Z = 10 
b. Width and Height: 10  

3. Under ‘Canvas Scalar (Script)’ element, set the ‘Dynamic Pixels Per Unit’ attribute to 10  

CREATING A MENU 



Now that we have our Canvas element in place, we’ll want to start adding objects to it! The first thing that we’ll do 
is put in a text element that will be our title. 

1. Select the Canvas in the Hierarchy and make sure it’s highlighted 
2. Right click while the Canvas is highlighted and click UI > Text to add a Text object to the Canvas 
3. Click on the Text object in the Hierarchy and change the following attributes in the Inspector: 

a. Position: X = 0, Y = 1.64, Z = 0 
b. Width: 100, Height: 50 
c. Scale: X, Y, Z = 0.1 

4. Under the Text (Script) attribute: 
a. Text: Give your application a name! 
b. Font Size: 20 
c. Horizontal and Vertical Overflow: Overflow 
d. Color: whatever you want! 

5. Click the Play button to view your title. You will see the world-locked text in space floating in front of the 
camera. Feel free to play around with the location as it suits you! 

ADDING AN ICON 

Once we’ve added our title, we’re going to go ahead and give our application an icon. The first thing we’ll want to 
do is bring in an image to use as our icon and convert it into a sprite: 

1. Find an image that you’d like to use (check licenses before using in your project!) or create your own icon. 
2. Import your icon by right clicking in the Assets panel and choosing Import New Asset and locating your 

file. For best results, use a .png file that has a transparent background. 
3. Select your newly imported file in the Assets panel to open the Inspector window 
4. Under ‘Texture Type’, select ‘Sprite (2D and UI) 
5. Click the Apply button 

Now that we have a sprite to use, we’re going to go ahead and add it as an image to our menu: 

1. With the Canvas selected, right click and add UI > Image 
2. Select the image and set the following attributes in the Inspector: 

a. Position: X = 0, Y = 0.1, Z = 10 
b. Width: 3, Height: 3 – though if you choose a non-square image, this may need to be different! 

3. Under the Image (Script) box, select the small circle to the right of the Source Image box and locate your 
new sprite in the Assets tab. You should see your sprite appear on your menu! 

Lastly, we want to add a button to our scene so that we can have the user click on it to launch the main scene. 

1. With the Canvas selected, right click and add UI > Button 
2. Select the button and set the following attributes in the Inspector: 

a. Position: X = 0, Y = -3.25, Z = 10 
b. Width: 10, Height: 2 

4. Select the small circle to the right of the Source Image box and select None (Sprite) 
5. Click the color to bring up the color selector and set the Alpha value to zero so that the button 

background is transparent 



6. Expand the Button object in the Inspector and click on the Text object that is a child of the button 
7. Change the text to “Begin” and set the overflow options to Overflow, as we did above 
8. Change the text scale to 0.1 for each value 
9. Change the text color to one that is visible against your skybox  

 

Test your menu’s appearance by running your experience! Now that we’ve finished laying out our UI here, we’ll 
move on to the next stage of our application by adding UI elements to our planets in the other scene. In Module 3, 
we’ll add scripted behaviors to our UI to control how it responds to user input! 

ADDING UI ELEMENTS TO 3D OBJECTS 

Switch over to your other scene by double clicking on it in the Asset window – make sure to save your main menu 
scene first! We’re going to add a UI to our planets to display the name and some information about the planet. 

1. Select one of the planets in your main scene by choosing the root object (top most parent) in the 
Inspector. 

2. Right click to create a new Empty object and name it ‘PlanetCanvas’ by double clicking the new Game 
Object in the inspector. 

3. On the PlanetCanvas object, right click and add UI > Canvas and then from Canvas, create a UI > Text 
element. 

4. Select the Canvas object in the Hierarchy and set the following attributes in the Inspector: 
a. Render Mode: World Space 
b. Position: X = 0, Y = 5, Z = 0 
c. Width and Height: 2 
d. Scale: X, Y, and Z = 0.5 
e. Dynamic Pixels Per Unit: 100 

5. Rotate the Canvas to face your camera 



6. Select the Text item that is a child of the Canvas we just added to our planet and set the following 
attributes: 

a. Position: X, Y, Z = 0 
b. Width and Height: 2 
c. Scale: X, Y, and Z = 0.1 
d. Set your Text to whatever planet you’ve selected 
e. Change your Text settings for both overflow options to Overflow 
f. Select the Best Fit checkbox and make the minimum font 0 

7. Press Play to view your scene and make any adjustments necessary! You may have to adjust the canvas’s 
scale, rotation, and location for the planet text to align. Play around with these values! Just make sure 
that if you are making changes in Game Play mode that you make a note of the final changes – they won’t 
be saved otherwise. 

 

You can turn your PlanetCanvas into a prefab object to make it easier to add text elements to other planets. 

1. In the Asset folder, right click and Create > Prefab. Name the Prefab PlanetCanvas. 
2. Drag your PlanetCanvas from the Hierarchy into the prefab. You can now use the PlanetCanvas prefab in 

your project by dragging the PlanetCanvas prefab object from your Assets folder onto a planet in the 
scene Hierarchy 

 

 

LOOKING AHEAD 



In our next module, we will begin learning about scripting in C# for Unity development and add in behaviors to our 
scenes to handle navigational elements and showing/hiding the UI that we have added to our planets when we 
“click” on them with our headset trigger. 

  



MODULE 3: INTRODUCTION TO C# AND SCRIPTING 
Powering a game experience is done by combining a series of interactive behaviors on game objects using scripts. 
These scripts can add character behaviors to NPCs, trigger a specific action or award for a user, show or hide other 
elements in the environment, change an object’s properties, and network physics objects together in a multiplayer 
experience – to name just a few things! In the Unity engine, scripts are primarily written in the C# programming 
language.  

SPECIFYING A BUILD ORDER 

The first thing that we’ll do before we get started on our script is change our default build settings in Unity now 
that we have two scenes. This will allow us to implement a navigation script that allows us to change scenes from 
our menu to our main app when the user triggers on the button! The scene indices (indicated by a number starting 
with 0) is how we can navigate programmatically via script to change between our app scenes. 

1. Launch Unity and open up your MainMenu scene. 

2. Open up the Build Settings by going to File > Build Settings. Add the MainMenu scene to the Build Settings 
dialog by clicking “Add Open Scenes”. Make sure that there is a 0 next to the MainMenu scene.  

 
3. Switch over to your Main Scene and repeat step 1, making sure that the main scene has a number 1 next 

to it in the Build Settings. Save and return to the MainMenu scene.  

EVENT SYSTEM MECHANICS 

The first thing we are going to do with our main menu scene is add the Google VR Gaze Input Module to our Event 
System. The Event System object listens for things going on in the scene and tells the UI elements when to respond 
accordingly. 

1. Open up the Main Menu scene by double clicking on it in the Asset window. 
2. Select the Event System in the Hierarchy and click the “Add Component” button in the Inspector. 
3. Select GoogleVR > GvrPointerInputModule and hit enter to add the component to the Event System. 
4. Click the small gear next to the Gaze Input Module and click “Move Up”. This will have gaze events trigger 

before normal input is processed. 
5. Under Assets > GoogleVR > Prefabs > Cardboard, find the GvrReticlePointer object and drag it on top of 

your Main Camera. This will add a viewing pointer to our gaze to track what we’re looking at within our 
scene. 

The Gvr Pointer Input Module is a script that Google provides through their VR SDK to allow the user to look at an 
object and use the single-button (or magnet) input on an object.  

CREATING OBJECT TRIGGERS 

Now that we have a way to manage the input we receive from the user’s gaze, we need to add triggers to our UI 
objects to add behaviors to them. In this scene, we will be adding a main scene launcher to our button to handle 
the interaction of looking at and “clicking” by triggering the hardware button – in our case, a magnet pull. 

1. Expand the Canvas item in the Hierarchy and select the Button element. 



2. In the Inspector for the Button, click the ‘Add Component’ button and search for “Event Trigger”. Hit 
enter to add the component to the button. 

3. Click the ‘Add Component’ button again and type in ‘LaunchMainScene’. When prompted, choose the 
option to Add New Script > C# Script. Name the script ‘LaunchMainScene and press enter to create and 
add the new script. 

4. Double click on the greyed out LaunchMainScene script to open up the script. By default, your script 
will launch in MonoDevelop or Visual Studio, depending on what you installed when you installed Unity. 

5. We are going to create a short function that will launch our main menu scene when our button is 
“pressed”. Replace the contents of the LaunchMainScene.cs file with the following and then save the file 
(CTRL/CMD + S): 

using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 
 
public class LaunchMainScene : MonoBehaviour 
{ 
    // Use this for initialization  
    void Start () { } 
 
    // Update is called once per frame  
    void Update () { } 
 
    // Navigate to main scene  
    public void OnClick() { 
        // We will load the first scene (this is scene 0)  
        UnityEngine.SceneManagement.SceneManager.LoadScene(1); 
    } 

 } 

Back in Unity, we need to add our script event OnClick() function to our button’s ‘OnClick’ behavior.  

1. Select the Button in your scene in the inspector. You should see your script added to the bottom of the 
component list.  

2. In the ‘OnClick’ section of the button components, click the small ‘+’ to add a space for our function to be 
called. 

3. From the button’s component list, drag the ‘LaunchMainScene’ instance that is attached to the button 
into the box that says None (Object). This will tell our button that we want it to self-reference its attached 
script and use that to power our click functionality.  

4. The button OnClick should now have a drop down menu. Select ‘LaunchMainScene > OnClick’ to hook up 
the button’s on click command to the one specified in our script.  

Try playing your scene and see how to simulate a trigger pull. You should see your application switch to your other 
scene! Notice how the reticle changes shape and size when it hovers over an interactable object.  

Consider what other menu types you might add for your app and how you would modify the LaunchMainScene 
script to navigate to other scenes.  Commented [LE3]: Add call-outs for these types of 
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ADDING UI ELEMENTS TO 3D OBJECTS 

The second half of adding UI elements to our scene is to add text to the planets that appear when the viewer looks 
at them, and hides it when it goes away. We will do a few things to support world UI in our solar system:  

 Add our gaze input modules into our main scene 
 Place a physics raycaster on the main camera 
 Create colliders for our planets 
 Use a simple script to show and hide the UI on the planets when gaze is detected 

GAZE INPUT FOR 3D OBJECTS 

1. Switch back to your Main Scene in the Unity editor.  
2. Following the steps above, add the GvrPointerInputModule to your Event System and the Gvr Reticle 

Pointer prefab to your Main Camera 
3. To interact with 3D objects instead of UI canvas elements, we will be adding an additional element to our 

camera – a physics raycaster. This will send out an invisible ray from the camera to detect collisions with 
solid objects. On your main camera, click ‘Add Component’ and add the ‘GvrPointerPhysicsRaycaster’ 
script. 

4. At the top of the inspector for the Main Camera, select Tag > MainCamera 
5. Select all of your planets by holding down CTRL / CMD and clicking on them in the Inspector.  
6. Click ‘Add Component’ and search for ‘Sphere Collider’, then hit enter to add the sphere colliders to each 

planet. 

BILLBOARD SCRIPT – CAMERA LOOK AT 

Once we have set up our camera to detect collisions with 3D objects, it’s time to add a new script to our 
PlanetCanvas prefab. The following ‘Billboard’ script will set up our text so that it is always facing the viewer. This is 
helpful in that we don’t have to worry about which way the text is oriented relative to the user. 

1. Select the PlanetCanvas prefab in the Assets window and click “Add Component” > “New C# Script”. 
Name the script “Billboard.cs” 
2. Open up Billboard.cs and copy the following into the script: 
using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 
 
public class Billboard : MonoBehaviour { 
 
 // Use this for initialization 
 void Start () { 
   
 } 
  
 // Update is called once per frame 
 void Update () { 
         transform.rotation = Quaternion.LookRotation(transform.position - 
Camera.main.transform.position); 
    } 
} 



 

By adding this to the prefab, all of our planets that are using the prefab will get the billboard script added to them 
automatically. 

SHOWING AND HIDING UI ELEMENTS 

The final part of our project is to set up the interactive element in our scene so that we can show and hide our UI 
when people interact with the planets. To do this, we are going to write a script that: 

 Rotates our planets around in space 
 Pauses when a viewer looks at them 
 Shows the text we added when the viewer “clicks” with the magnet 
 Auto-hides the text and resumes rotating when the viewer looks away 

To add the script: 

1. Right click in the Assets window and create New > C# Script. Name the script “PlanetScript.cs” 
2. Copy the below code into PlanetScript.cs: 
using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 
using UnityEngine.UI; 
 
 /// <summary> 
 /// Variables for the planet script  
 /// Controls rotation  
 /// On gaze + trigger, show UI  
 /// When gaze Edits, hide UI  
 /// </summary> 
 
public class PlanetScript : MonoBehaviour {  
    // Public variables  
    public float planetRotationSpeed; // For animating the planet movement 
 
    // Private variables  
    bool isRotating = true; 
     
    // Use this for initialization 
    void Start () {} 
  
    // Update is called once per frame 
    void Update () { 
     if (isRotating) { 
        gameObject.transform.Rotate(new Vector3(0.0f, planetRotationSpeed, 
0.0f)); 
        } 
    } 
 
    /// <summary>  
    /// Show or hide the UI based on whether or not it is showing already  
    /// Will be called with EventTrigger OnPointerClick  
    /// </summary>  



    public void ShowHideUIDetails() { 
        isRotating = false; 
        GetComponentInChildren<Canvas>().enabled = 
!GetComponentInChildren<Canvas>().enabled; 
        
GetComponentInChildren<Canvas>().GetComponent<CanvasScaler>().dynamicPixelsPer
Unit = 100; 
    } 
 
    /// <summary>  
    /// Hide the UI for a planet when the user stops looking at it 
    /// Will be called with EventTrigger OnPointerExit  
    /// </summary>  
    public void HideUIWhenGazeExit() { 
        GetComponentInChildren<Canvas>().enabled = false; 
        isRotating = true; 
    } 
} 
3. Select all of your planets in the Hierarchy by holding down CTRL/CMD and selecting them from the 
hierarchy, then click “Add Component”.  
4. Type in “PlanetScript” and add it to your planets.  
5. Like before, we will need to add in EventTriggers for our planets. You will have to do this individually for 
each planet: 

a. Select the planet and Add Component > Event Trigger  
b. Add the Pointer Click trigger, select the planet, and choose ShowHideUIDetails 
c. Click Add New Event Type and choose Pointer Exit 
d. Select the planet, and choose HideUIWhenGazeExit 

Click Play and spend some time viewing your different planets! 
  



MODULE 4: BUILDING YOUR APPLICATION 

THE BUILD PROCESS  

Building an application is when Unity exports the project that you’ve made into a file format that can be run by a 
specific device. More generally speaking, building is part of the process that turns human-written code into 
computer-readable code.  

Unity provides multiple options for building applications: you can choose a variety of platforms. Today we’re going 
to focus on Android and iOS to fit with our use of the Cardboard SDK. Generally, your build process will involve:  

 Switching your Unity player to your desired platform if you haven’t already  
 Adding your scenes into the build window  
 Defining player settings  
 Building to an app or a project  
 Deploying  

ANDROID INSTRUCTIONS  

Use these instructions if you are building your VR Space application to use Cardboard on an Android phone.  

INSTALL THE ANDROID SDK & JAVA JDK  

1. Download and install the Android SDK from https://developer.android.com/studio/#downloads. You do 
not need to download Android Studio, just the SDK tools package:  

 
2. You may need to install the Java development kit as part of the installation process for the Android SDK. 

You can download the Java JDK at the following link, or from the link in the Android installer: 
https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html  



 

Select the radio button for Accept License Agreement, and then download the file associated with the 
Product/File Description that matches your system.  

 If you are running on a Macbook, select Mac OS X  
 If you are running a 64-bit version of Windows, choose x64 – for a 32-bit system, choose the x86 version. 

You can find your system information by going to Settings > System > About and looking at System Type  

 



3. Once you have installed the Java SDK, you can continue with the Android installation. I recommend installing the 
SDK into a folder you will remember easily (e.g. Documents\Android or a similar location)  

 

BUILD FROM UNITY  

Before we start our Android Build, we must add a few project settings.  

1. Open the Player Settings by going to Edit > Project Settings > Player. The Player Settings will open in the 
Inspector window.  
2. Add your scenes to the build using the Add Open Scene button  
3. Change your “Company Name”, “product name”, and “Bundle Identifier” (under Other Settings > 
Identification) to unique names. You’d replace these with your own information in a finalized app:  

a. Company Name: “mycompany”  
b. Product Name: “demoapp”  
c. Bundle Identifier: “com.mycompany.demoapp”  

4. Click Build.  
5. Specify a name and location to save your sample application.  

When you first build from Unity, you will need to tell Unity where your Android SDK is located. Open File > Build 
Settings and choose Android, then click Build to start the process.  

1. When Unity asks, find the main folder for your Android SDK installation location and click OK.  
2. If prompted, allow Unity to install and update additional packages.  

Once your application finishes building, you can copy and paste it over to your phone to install it. You may need to 
enable applications from any source (developer mode) on your phone before you can install your own application.  

IOS BUILD INSTRUCTIONS  

In order to build for iOS, you MUST have access to a Mac computer with XCode installed. You can download XCode 
from the Mac App Store. Unlike with Android, Unity will not produce a full runnable application for iOS, and will 
instead produce a project folder that needs to be compiled with XCode.  

You must also create a developer account with Apple and provision this for your device. You can find instructions 
for this here: https://help.apple.com/xcode/mac/current/#/dev60b6fbbc7  

Google has additional instructions on their site: https://developers.google.com/cardboard/unity/get-started-ios   

1. Open up the Build window and choose iOS.  
2. XCode will build a project folder—enter a name for your folder and click OK to kick off the process.  
3. When the build has finished, open XCode and attach your iOS device to your computer.  
4. Click the Unity-iPhone project icon at the top of the list in XCode.  
5. Under 'Identity', choose a bundle identifier in the form above:  

a. Bundle Identifier: “com.mycompany.demoapp”  
6. On your iOS device, go to General > Profile > select the email address used and select it as a trusted 
device.  
7. Back in XCode, play your app to launch it on your device!  
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